【Eclipse】Open Type Hierarchy action 中に内部エラーが発生しました【PDT】

PDT で HTML + PHP を書いてると…

Eclipse 4.PDTちゃんでCakePHP のViewを書いていると、入力途中に自動デバッグが走って構文エラーを検出したとき(?)に、ときどき

Open Type Hierarchy action 中に内部エラーが発生しました

2016-10-17_13h30_34

という「複数の問題が発生しました」というウィンドウが出て快速コーディングを全力で阻止されます(>_<)

一度出始めると、連続で発生しまくって作業になりません(>_<)
ええ、ブチ切れですとも。

通常のアップデートをしても直らない…ので

困ったときはアップデートすりゃ直してくれてるんだよ!と思って更新の確認をしても

2016-10-18_11h45_00

と無情なメッセージが出てきてどうしようもありません。

ググってもあまり出てこないのですが(探し方がわるい?)、nightlyビルドから更新を掛けると解消されるみたいなので、やってみました。

 

ヘルプ→新規ソフトウェアのインストール

2016-10-18_11h23_25

 

「作業対象」にnightlyビルドのurlを入力

http://download.eclipse.org/tools/pdt/updates/latest-nightly/

しばらく待つ。

2016-10-17_13h31_33

PDTの4.2.0.20161015版とやらが出てきました( ´▽`)

利用可能なパッケージ一覧が出てきます。一番上のPDTだけでいいかな…と1つだけインストールしたら、コンソールにめっちゃエラーが出てまともに動かなかったので、めんどくさくなって全部チェック入れてやりなおしてる画面です(^_^;

2016-10-17_13h36_38

アップデート確認。次へ。

ライセンス情報を確認して…

2016-10-17_13h31_49

インストール/更新開始

2016-10-17_13h35_22

一度、PDTだけを中途半端に入れてしまったので、途中で処理が続行できなくなったとのメッセージが出ていますが、気長に待っていると、勝手に解決策をみつけて修正してくれました。ステキ。

インストール終了後、再起動します。

2016-10-17_13h37_51

スプラッシュはとくに変わっていないですが…。

あれ、ワークスペースがリセットされた(>_<)

2016-10-17_13h38_19

更新じゃなくて新規インストール扱いだから…?いままでのワークスペース開いてもうまく開けず…ワーキングセットとかどっかいったw

私はほとんどデフォルト設定で使ってるレベルなので、問題なかったのですが、環境などこだわっている人はバックアップを取ってから作業しましょう(´д`)

改善した…?

とりあえず更新した状態で、2日ほど使い続けていますが、いまのところ「Open Type Hierarchy action 中に内部エラーが発生しました」は出ていません、この件に関しては直ったのかな。…ということで、いつもの投げっぱなし記事でした。

コメントを残す

メールアドレスが公開されることはありません。